[build system] weird mvn errors post-cache cleaning

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[build system] weird mvn errors post-cache cleaning

shane knapp
a bunch of the PRB builds are now failing w/various permutations of
the following:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-install-plugin:3.0.0-M1:install
(default-cli) on project spark-sql-kafka-0-10_2.12:
ArtifactInstallerException: Failed to install metadata
org.apache.spark:spark-sql-kafka-0-10_2.12/maven-metadata.xml: Could
not parse metadata
/home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml:
in epilog non whitespace content is not allowed but got t (position:
END_TAG seen ...</metadata>\nt... @13:2) -> [Help 1]

when looking at the file on this worker:
-bash-4.1$ cat -Avet
/home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml
<?xml version="1.0" encoding="UTF-8"?>$
<metadata>$
  <groupId>org.apache.spark</groupId>$
  <artifactId>spark-sql-kafka-0-10_2.12</artifactId>$
  <versioning>$
    <release>spark-346687</release>$
    <versions>$
      <version>spark-346687</version>$
    </versions>$
    <lastUpdated>20190917192919</lastUpdated>$
  </versioning>$
</metadata>$

(sorry for the terminal font setup, but there are no erroneous control
characters popping up, and -e shows a $ at EOL)

i'm confused that this is happening.  anyone have any ideas?
--
Shane Knapp
UC Berkeley EECS Research / RISELab Staff Technical Lead
https://rise.cs.berkeley.edu

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [build system] weird mvn errors post-cache cleaning

Sean Owen-2
That's super weird; can you just delete ~/.m2 and let it download the
internet again? or at least blow away the downloaded Kafka dir?
Turning it on and off, so to speak, often works.

On Tue, Sep 17, 2019 at 2:41 PM Shane Knapp <[hidden email]> wrote:

>
> a bunch of the PRB builds are now failing w/various permutations of
> the following:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-install-plugin:3.0.0-M1:install
> (default-cli) on project spark-sql-kafka-0-10_2.12:
> ArtifactInstallerException: Failed to install metadata
> org.apache.spark:spark-sql-kafka-0-10_2.12/maven-metadata.xml: Could
> not parse metadata
> /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml:
> in epilog non whitespace content is not allowed but got t (position:
> END_TAG seen ...</metadata>\nt... @13:2) -> [Help 1]
>
> when looking at the file on this worker:
> -bash-4.1$ cat -Avet
> /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml
> <?xml version="1.0" encoding="UTF-8"?>$
> <metadata>$
>   <groupId>org.apache.spark</groupId>$
>   <artifactId>spark-sql-kafka-0-10_2.12</artifactId>$
>   <versioning>$
>     <release>spark-346687</release>$
>     <versions>$
>       <version>spark-346687</version>$
>     </versions>$
>     <lastUpdated>20190917192919</lastUpdated>$
>   </versioning>$
> </metadata>$
>
> (sorry for the terminal font setup, but there are no erroneous control
> characters popping up, and -e shows a $ at EOL)
>
> i'm confused that this is happening.  anyone have any ideas?
> --
> Shane Knapp
> UC Berkeley EECS Research / RISELab Staff Technical Lead
> https://rise.cs.berkeley.edu
>
> ---------------------------------------------------------------------
> To unsubscribe e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [build system] weird mvn errors post-cache cleaning

shane knapp
that's what i literally just did!  i wiped the .m2, .ivy and
per-executor sbt caches on all of these machines.

maybe it was just a network burp.

also, it's only 2 builds:
https://amplab.cs.berkeley.edu/jenkins/job/SparkPullRequestBuilder/110809/console
https://amplab.cs.berkeley.edu/jenkins/job/SparkPullRequestBuilder/110800/console

i'll keep an eye on things and re-ping the list if i see more failures
like this.

devs, if you see weird failures like this in your builds reply here
and i'll take a closer look.

On Tue, Sep 17, 2019 at 12:52 PM Sean Owen <[hidden email]> wrote:

>
> That's super weird; can you just delete ~/.m2 and let it download the
> internet again? or at least blow away the downloaded Kafka dir?
> Turning it on and off, so to speak, often works.
>
> On Tue, Sep 17, 2019 at 2:41 PM Shane Knapp <[hidden email]> wrote:
> >
> > a bunch of the PRB builds are now failing w/various permutations of
> > the following:
> >
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-install-plugin:3.0.0-M1:install
> > (default-cli) on project spark-sql-kafka-0-10_2.12:
> > ArtifactInstallerException: Failed to install metadata
> > org.apache.spark:spark-sql-kafka-0-10_2.12/maven-metadata.xml: Could
> > not parse metadata
> > /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml:
> > in epilog non whitespace content is not allowed but got t (position:
> > END_TAG seen ...</metadata>\nt... @13:2) -> [Help 1]
> >
> > when looking at the file on this worker:
> > -bash-4.1$ cat -Avet
> > /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml
> > <?xml version="1.0" encoding="UTF-8"?>$
> > <metadata>$
> >   <groupId>org.apache.spark</groupId>$
> >   <artifactId>spark-sql-kafka-0-10_2.12</artifactId>$
> >   <versioning>$
> >     <release>spark-346687</release>$
> >     <versions>$
> >       <version>spark-346687</version>$
> >     </versions>$
> >     <lastUpdated>20190917192919</lastUpdated>$
> >   </versioning>$
> > </metadata>$
> >
> > (sorry for the terminal font setup, but there are no erroneous control
> > characters popping up, and -e shows a $ at EOL)
> >
> > i'm confused that this is happening.  anyone have any ideas?
> > --
> > Shane Knapp
> > UC Berkeley EECS Research / RISELab Staff Technical Lead
> > https://rise.cs.berkeley.edu
> >
> > ---------------------------------------------------------------------
> > To unsubscribe e-mail: [hidden email]
> >



--
Shane Knapp
UC Berkeley EECS Research / RISELab Staff Technical Lead
https://rise.cs.berkeley.edu

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [build system] weird mvn errors post-cache cleaning

shane knapp
ah, i found this sucker on amp-jenkins-worker-02:
-bash-4.1$ cat /home/jenkins/.m2/repository/org/apache/spark/spark-parent_2.12/maven-metadata-local.xml
<?xml version="1.0" encoding="UTF-8"?>
<metadata>
  <groupId>org.apache.spark</groupId>
  <artifactId>spark-parent_2.12</artifactId>
  <versioning>
    <release>spark-155410</release>
    <versions>
      <version>spark-155410</version>
    </versions>
    <lastUpdated>20190917185916</lastUpdated>
  </versioning>
</metadata>
tUpdated>  <----------- not good!
  </versioning>
</metadata>

i rmed that file and hopefully it will repopulate w/o issue.  if not,
i'll kill builds on that worker and wipe all local caches.  again.

On Tue, Sep 17, 2019 at 12:53 PM Shane Knapp <[hidden email]> wrote:

>
> that's what i literally just did!  i wiped the .m2, .ivy and
> per-executor sbt caches on all of these machines.
>
> maybe it was just a network burp.
>
> also, it's only 2 builds:
> https://amplab.cs.berkeley.edu/jenkins/job/SparkPullRequestBuilder/110809/console
> https://amplab.cs.berkeley.edu/jenkins/job/SparkPullRequestBuilder/110800/console
>
> i'll keep an eye on things and re-ping the list if i see more failures
> like this.
>
> devs, if you see weird failures like this in your builds reply here
> and i'll take a closer look.
>
> On Tue, Sep 17, 2019 at 12:52 PM Sean Owen <[hidden email]> wrote:
> >
> > That's super weird; can you just delete ~/.m2 and let it download the
> > internet again? or at least blow away the downloaded Kafka dir?
> > Turning it on and off, so to speak, often works.
> >
> > On Tue, Sep 17, 2019 at 2:41 PM Shane Knapp <[hidden email]> wrote:
> > >
> > > a bunch of the PRB builds are now failing w/various permutations of
> > > the following:
> > >
> > > [ERROR] Failed to execute goal
> > > org.apache.maven.plugins:maven-install-plugin:3.0.0-M1:install
> > > (default-cli) on project spark-sql-kafka-0-10_2.12:
> > > ArtifactInstallerException: Failed to install metadata
> > > org.apache.spark:spark-sql-kafka-0-10_2.12/maven-metadata.xml: Could
> > > not parse metadata
> > > /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml:
> > > in epilog non whitespace content is not allowed but got t (position:
> > > END_TAG seen ...</metadata>\nt... @13:2) -> [Help 1]
> > >
> > > when looking at the file on this worker:
> > > -bash-4.1$ cat -Avet
> > > /home/jenkins/.m2/repository/org/apache/spark/spark-sql-kafka-0-10_2.12/maven-metadata-local.xml
> > > <?xml version="1.0" encoding="UTF-8"?>$
> > > <metadata>$
> > >   <groupId>org.apache.spark</groupId>$
> > >   <artifactId>spark-sql-kafka-0-10_2.12</artifactId>$
> > >   <versioning>$
> > >     <release>spark-346687</release>$
> > >     <versions>$
> > >       <version>spark-346687</version>$
> > >     </versions>$
> > >     <lastUpdated>20190917192919</lastUpdated>$
> > >   </versioning>$
> > > </metadata>$
> > >
> > > (sorry for the terminal font setup, but there are no erroneous control
> > > characters popping up, and -e shows a $ at EOL)
> > >
> > > i'm confused that this is happening.  anyone have any ideas?
> > > --
> > > Shane Knapp
> > > UC Berkeley EECS Research / RISELab Staff Technical Lead
> > > https://rise.cs.berkeley.edu
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe e-mail: [hidden email]
> > >
>
>
>
> --
> Shane Knapp
> UC Berkeley EECS Research / RISELab Staff Technical Lead
> https://rise.cs.berkeley.edu



--
Shane Knapp
UC Berkeley EECS Research / RISELab Staff Technical Lead
https://rise.cs.berkeley.edu

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [build system] weird mvn errors post-cache cleaning

shane knapp
> ah, i found this sucker on amp-jenkins-worker-02:

s/02/06

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [build system] weird mvn errors post-cache cleaning

Dongjoon Hyun-2
Oh, thank you for fixing that! :)

Bests,
Dongjoon.

On Tue, Sep 17, 2019 at 12:57 PM Shane Knapp <[hidden email]> wrote:
> ah, i found this sucker on amp-jenkins-worker-02:

s/02/06

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]