[SQL] Two ScalarSubquery expressions?! Could we have ScalarSubqueryExec instead?
Just been bitten by finding out that there are two ScalarSubquery expressions, one is a SubqueryExpression  and another is a ExecSubqueryExpression .
Could we have the ExecSubqueryExpression subclass called ScalarSubqueryExec to follow the naming convention in logical and physical plans? That'd help a lot (and I doubt I'm the only one confused). Thanks.