This is just an extra unnecessary direct usage of the "sparkConf" member val (those two lines are added by two different PRs).
Actually both uses the same "sparkConf" to give back the config value, as
"KubernetesExecutorConf" extends the "KubernetesConf"  which uses the
passed "sparkConf" to get back the value in the get method .
So technically this does not cause any problem but it is better to harmonize
it and call the contains method directly on "kubernetesConf" (see the
method ) to avoid confusion for the next readers.