CVE-2017-12612 Unsafe deserialization in Apache Spark launcher API

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

CVE-2017-12612 Unsafe deserialization in Apache Spark launcher API

Sean Owen-3
Severity: Medium

Vendor: The Apache Software Foundation

Versions Affected:
Versions of Apache Spark from 1.6.0 until 2.1.1

Description:
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe
deserialization of data received by  its socket. This makes applications
launched programmatically using the launcher API potentially
vulnerable to arbitrary code execution by an attacker with access to any user
account on the local machine. It does not affect apps run by spark-submit or
spark-shell. The attacker would be able to execute code as the user that ran
the Spark application. Users are encouraged to update to version 2.2.0 or
later.

Mitigation:
Update to Apache Spark 2.2.0 or later.

Credit:
Aditya Sharad, Semmle