Build error: python/lib/pyspark.zip is not a ZIP archive

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Build error: python/lib/pyspark.zip is not a ZIP archive

Jeff Evans
Greetings,

I'm getting an error when building, on latest master (2bd873181 as of this writing).  Full build command I'm running is: ./build/mvn -DskipTests clean package

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (create-tmp-dir) on project spark-assembly_2.12: An Ant BuildException has occured: Problem reading /Users/jeff/dev/spark/python/lib/pyspark.zip
[ERROR] around Ant part ...<zip destfile="/Users/jeff/dev/spark/assembly/../python/lib/pyspark.zip">... @ 6:76 in /Users/jeff/dev/spark/assembly/target/antrun/build-main.xml: archive is not a ZIP archive
[ERROR] -> [Help 1]


Trying to run unzip -l python/lib/pyspark.zip does seem to suggest it's not a valid zip file.  Any ideas what might be wrong?  I tried searching the archives and didn't see anything relevant.  Thanks.
  • OS X Catalina 10.5.2
  • OpenJDK 1.8.0_212
  • Maven 3.6.3
  • Python 3.8.1 (via pyenv)
Reply | Threaded
Open this post in threaded view
|

Re: Build error: python/lib/pyspark.zip is not a ZIP archive

Sean Owen-2
Sounds like you might have some corrupted file locally. I don't see
any of the automated test builders failing. Nuke your local assembly
build and try again?

On Fri, Jan 10, 2020 at 3:49 PM Jeff Evans
<[hidden email]> wrote:

>
> Greetings,
>
> I'm getting an error when building, on latest master (2bd873181 as of this writing).  Full build command I'm running is: ./build/mvn -DskipTests clean package
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (create-tmp-dir) on project spark-assembly_2.12: An Ant BuildException has occured: Problem reading /Users/jeff/dev/spark/python/lib/pyspark.zip
> [ERROR] around Ant part ...<zip destfile="/Users/jeff/dev/spark/assembly/../python/lib/pyspark.zip">... @ 6:76 in /Users/jeff/dev/spark/assembly/target/antrun/build-main.xml: archive is not a ZIP archive
> [ERROR] -> [Help 1]
>
> Trying to run unzip -l python/lib/pyspark.zip does seem to suggest it's not a valid zip file.  Any ideas what might be wrong?  I tried searching the archives and didn't see anything relevant.  Thanks.
>
> OS X Catalina 10.5.2
> OpenJDK 1.8.0_212
> Maven 3.6.3
> Python 3.8.1 (via pyenv)

---------------------------------------------------------------------
To unsubscribe e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Build error: python/lib/pyspark.zip is not a ZIP archive

Jeff Evans
Thanks for the tip.  Fixed by simply removing python/lib/pyspark.zip (since it's apparently generated), and rebuilding.  I guess clean does not remove it.

On Fri, Jan 10, 2020 at 3:50 PM Sean Owen <[hidden email]> wrote:
Sounds like you might have some corrupted file locally. I don't see
any of the automated test builders failing. Nuke your local assembly
build and try again?

On Fri, Jan 10, 2020 at 3:49 PM Jeff Evans
<[hidden email]> wrote:
>
> Greetings,
>
> I'm getting an error when building, on latest master (2bd873181 as of this writing).  Full build command I'm running is: ./build/mvn -DskipTests clean package
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (create-tmp-dir) on project spark-assembly_2.12: An Ant BuildException has occured: Problem reading /Users/jeff/dev/spark/python/lib/pyspark.zip
> [ERROR] around Ant part ...<zip destfile="/Users/jeff/dev/spark/assembly/../python/lib/pyspark.zip">... @ 6:76 in /Users/jeff/dev/spark/assembly/target/antrun/build-main.xml: archive is not a ZIP archive
> [ERROR] -> [Help 1]
>
> Trying to run unzip -l python/lib/pyspark.zip does seem to suggest it's not a valid zip file.  Any ideas what might be wrong?  I tried searching the archives and didn't see anything relevant.  Thanks.
>
> OS X Catalina 10.5.2
> OpenJDK 1.8.0_212
> Maven 3.6.3
> Python 3.8.1 (via pyenv)
Reply | Threaded
Open this post in threaded view
|

Re: Build error: python/lib/pyspark.zip is not a ZIP archive

Jeff Evans
Actually, there is a really trivial fix for that (an existing file not being deleted when packaging).  Opened SPARK-30489 for it.

On Fri, Jan 10, 2020 at 3:52 PM Jeff Evans <[hidden email]> wrote:
Thanks for the tip.  Fixed by simply removing python/lib/pyspark.zip (since it's apparently generated), and rebuilding.  I guess clean does not remove it.

On Fri, Jan 10, 2020 at 3:50 PM Sean Owen <[hidden email]> wrote:
Sounds like you might have some corrupted file locally. I don't see
any of the automated test builders failing. Nuke your local assembly
build and try again?

On Fri, Jan 10, 2020 at 3:49 PM Jeff Evans
<[hidden email]> wrote:
>
> Greetings,
>
> I'm getting an error when building, on latest master (2bd873181 as of this writing).  Full build command I'm running is: ./build/mvn -DskipTests clean package
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (create-tmp-dir) on project spark-assembly_2.12: An Ant BuildException has occured: Problem reading /Users/jeff/dev/spark/python/lib/pyspark.zip
> [ERROR] around Ant part ...<zip destfile="/Users/jeff/dev/spark/assembly/../python/lib/pyspark.zip">... @ 6:76 in /Users/jeff/dev/spark/assembly/target/antrun/build-main.xml: archive is not a ZIP archive
> [ERROR] -> [Help 1]
>
> Trying to run unzip -l python/lib/pyspark.zip does seem to suggest it's not a valid zip file.  Any ideas what might be wrong?  I tried searching the archives and didn't see anything relevant.  Thanks.
>
> OS X Catalina 10.5.2
> OpenJDK 1.8.0_212
> Maven 3.6.3
> Python 3.8.1 (via pyenv)